Re: [AMBER-Developers] simplified install process (e.g: no AMBERHOME, no sourcing amber.sh)

From: Jason Swails <jason.swails.gmail.com>
Date: Sat, 11 Feb 2017 18:57:50 -0500

On Sat, Feb 11, 2017 at 5:59 PM, Scott Brozell <sbrozell.rci.rutgers.edu>
wrote:

> Hi,
>
> On Sat, Feb 11, 2017 at 10:50:54AM -0500, Hai Nguyen wrote:
> > On Sat, Feb 11, 2017 at 10:34 AM, David Case <david.case.rutgers.edu>
> wrote:
> > > On Fri, Feb 10, 2017, Hai Nguyen wrote:
> > >
> > > > PS2: "NEW" won't work with --skip-python option (there is no Python
> code
> > > > to wrap "nab" program to set LD_LIBRARY_PATH)
> > >
> > > Can't you use a shell script instead?....dac
> > >
> > I do no want to support various shell types (like amber.sh, amber.csh).
> >
> > But If I try hard, I can make "NEW" work with "--skip-python" by trying
> > various python version.
> > However, it's hard to install python2.4 nowadays so I don't have any to
> > test my change.
>
> I don't know the details here, but i strongly prefer to have an
> installation process that does not need python; i might settle for
> a process that will work with any python.
>

‚Äčupdate_amber already requires Python, but works with every version in any
OS I've ever seen run Amber. I just tested Hai's new stuff with Python 2.4
(and --skip-python) and it works. So I don't think there's anything to
worry about here.

All the best,
Jason

-- 
Jason M. Swails
_______________________________________________
AMBER-Developers mailing list
AMBER-Developers.ambermd.org
http://lists.ambermd.org/mailman/listinfo/amber-developers
Received on Sat Feb 11 2017 - 16:00:02 PST
Custom Search