Re: [AMBER-Developers] configure --prefix

From: Hai Nguyen <nhai.qn.gmail.com>
Date: Mon, 6 Feb 2017 14:07:48 -0500

On Mon, Feb 6, 2017 at 1:47 PM, Jason Swails <jason.swails.gmail.com> wrote:

> On Mon, Feb 6, 2017 at 10:30 AM, David Case <david.case.rutgers.edu>
> wrote:
>
> > On Mon, Feb 06, 2017, Ross Walker wrote:
> >
> > > So does this mean we are officially dropping RHEL 6 support?
> >
> > No. Amber users are provided (via conda) with the correct python
> > (currently version 2.7). Amber codes will not use the system-supplied
> > python,
> > and hence won't care what version (if any) RHEL supplies.
> >
> > Note: there are still some glitches involved in this transition, but I
> > think
> > we are close.... Note that almost all users have been downloading their
> > python from Contiuum since April of 2016, and so have not been relying
> > on the system python for some time.
> >
> > [For personal reasons, some Amber users/developers may wish to
> > use another python version. Since they are experts in python, they are
> > welcome to do this. Much of the recent back-and-forth about python
> > involves
> > how much hand-holding we should provide for people who don't want to use
> > the python we supply.]
> >
>
> ‚ÄčThis is a slight wrinkle, I think. Unlike some other packages (like
> OpenMM), Python is not central to Amber's functionality, and there are
> realistic use-cases to not worrying about Python at all. If someone uses
> --skip-python, I think it's highly desirable that the build not then fail
> with a Python-related issue :).
>
> There are *some* components that depend on Python in all cases. A notable
> example is update_amber, which I wrote to be Python 2.4 -- Python 3.x
> compatible specifically so it would run anywhere.




> Since what Hai wrote was
> a small utility to do some post-processing, that should be done in a way
> that doesn't depend on having a specific version of Python (or any
> dependencies) if at all possible, in my opinion.
>
>
I am working on this. Still figuring how out how to install python 2.4 to
test :D
(conda only hep install python >= 2.6). And yes, I try to follow
 "update_amber"'s spirit.


Hai


> Thanks,
> Jason
>
> --
> Jason M. Swails
> _______________________________________________
> AMBER-Developers mailing list
> AMBER-Developers.ambermd.org
> http://lists.ambermd.org/mailman/listinfo/amber-developers
>
_______________________________________________
AMBER-Developers mailing list
AMBER-Developers.ambermd.org
http://lists.ambermd.org/mailman/listinfo/amber-developers
Received on Mon Feb 06 2017 - 11:30:03 PST
Custom Search